Проверка на четность excel

Для извлечения из таблицы только четных или нечетных строк можно использовать формулы и Автофильтр.

Пусть имеется исходная таблица с объемами продаж товаров по кварталам.

Нам требуется отобразить только четные или нечетные строки.

Примечание: О выделении нечетных строк Условным форматированием читайте в статье о Чрезстрочном выделении.

Автофильтр

Это можно легко сделать с помощью Автофильтра в столбце F. Для этого в ячейку F8 введите формулу =ЕЧЁТН(СТРОКА()-СТРОКА($F$7)) и скопируйте ее вниз. Формула для четных строк таблицы (не листа!) возвращает ИСТИНА.

Теперь с помощью Автофильтра можно выбрать либо четные либо нечетные строки.

Формулы

Выведем четные и нечетные строки с помощью формул.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$21))*2) можно отобрать только четные строки из исходной таблицы.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$30))*2-1) можно отобрать только нечетные строки.

В этой статье описаны синтаксис формулы и использование функции ЕЧЁТН в Microsoft Excel.

Описание

Возвращает значение ИСТИНА, если число четное, и значение ЛОЖЬ, если число нечетное.

Синтаксис

Аргументы функции ЕЧЁТН описаны ниже.

Число Обязательный. Проверяемое значение. Если число не является целым, оно усекается.

Замечания

Если значение аргумента "число" не является числом, функция ЕЧЁТН возвращает значение ошибки #ЗНАЧ!.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Проверяет, является ли число -1 четным

Проверяет, является ли число 2,5 четным. Дробная часть (0,5) усекается, поэтому проверяется число 2.

Читайте также:  Приложение винкс для смарт тв

Проверяет, является ли число 5 четным.

Нуль (0) считается четным.

Проверяет дату в ячейке A6. Десятичное представление даты 23.12.2011 — 40900.

Get expert help now

Don’t have time to figure this out? Our expert partners at Excelchat can do it for you, 24/7.

Когда нужно приготовить разного рода отчеты, иногда возникает потребность выделить все парные и непарные числа разными цветами. Для решения данной задачи наиболее рациональным способом является условное форматирование.

Как найти четные числа в Excel

Набор четных и нечетных чисел, которые следует автоматически выделить разными цветами:

Допустим парные числа нам нужно выделит зеленым цветом, а непарные – синим.

  1. Выделите диапазон ячеек A1:A8 и выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило».
  2. Ниже выберите: «Использовать формулу для определения форматируемых ячеек».
  3. Чтобы найти четное число в Excel ниже введите формулу: =ОСТАТ(A1;2)=0 и нажмите на кнопку «Формат», чтобы задать зеленый цвет заливки ячеек. И нажмите ОК на всех открытых окнах.
  4. Чтобы додать второе условие, не снимая выделения с диапазона A1:A8, снова выбираем инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило»-«Использовать формулу для определения форматируемых ячеек».
  5. В поле ввода введите формулу: =ОСТАТ(A1;2)<>0 и нажмите на кнопку «Формат», чтобы задать синий цвет заливки ячеек. И нажмите ОК на всех открытых окнах.
  6. К одному и тому же диапазону должно быть применено 2 правила условного форматирования. Чтобы проверить выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Управление правилами»

Две формулы отличаются только операторами сравнения перед значением 0. Закройте окно диспетчера правил нажав на кнопку ОК.

В результате у нас ячейки, которые содержат непарное число имеют синий цвет заливки, а ячейки с парными числами – зеленый.

Функция ОСТАТ в Excel для поиска четных и нечетных чисел

Функция =ОСТАТ() возвращает остаток от деления первого аргумента на второй. В первом аргументе мы указываем относительную ссылку, так как данные берутся из каждой ячейки выделенного диапазона. В первом правиле условного форматирования мы указываем оператор «равно» =0. Так как любое парное число, разделенное на 2 (второй оператор) имеет остаток от деления 0. Если в ячейке находится парное число формула возвращает значение ИСТИНА и присваивается соответствующий формат. В формуле второго правила мы используем оператор «неравно» <>0. Таким образом выделяем синим цветом нечетные числа в Excel. То есть принцип работы второго правила действует обратно пропорционально первому правилу.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock detector