Стандартная функция

Дробные числа в электронных таблицах Excel можно выводить на экран с разной степенью точности:

  • самый простой способ – на вкладке «Главная» нажимаем кнопки «Увеличить разрядность» или «Уменьшить разрядность»;
  • щелкаем правой кнопкой мыши по ячейке, в раскрывшемся меню выбираем «Формат ячеек…», далее вкладка «Число», выбираем формат «Числовой», определяем, сколько будет десятичных знаков после запятой (по умолчанию предлагается 2 знака);
  • щелкаем ячейку, на вкладке «Главная» выбираем «Числовой», либо идем на «Другие числовые форматы…» и там настраиваем.

Вот как выглядит дробь 0,129, если менять количество десятичных знаков после запятой в формате ячейки:

Обратите внимание, в A1,A2,A3 записано одно и то же значение, меняется только форма представления. При дальнейших расчетах будет использоваться не величина, видимая на экране, а исходная. Начинающего пользователя электронных таблиц это может слегка запутать. Чтобы реально изменить значение, необходимо использовать специальные функции, их в Excel несколько.

Формула округление

Одна из часто применяемых функций округления – ОКРУГЛ. Она работает по стандартным математическим правилам. Выбираем ячейку, щелкаем значок «Вставить функцию», категория «Математические», находим ОКРУГЛ.

Определяем аргументы, их два – сама дробь и количество разрядов. Щелкаем «ОК» и смотрим, что получилось.

К примеру, выражение =ОКРУГЛ(0,129;1) даст результат 0,1. Нулевое количество разрядов позволяет избавляться от дробной части. Выбор отрицательного количества разрядов позволяет округлять целую часть до десятков, сотен и так далее. Например, выражение =ОКРУГЛ(5,129;-1) даст 10.

Округляем в большую или меньшую сторону

В Excel представлены и другие средства, позволяющие работать с десятичными дробями. Одно из них – ОКРУГЛВВЕРХ, выдает самое близкое число, большее по модулю. Например, выражение =ОКРУГЛВВЕРХ(-10,2;0) даст -11. Количество разрядов здесь 0, значит, получим целое значение. Ближайшее целое, большее по модулю, – как раз -11. Пример использования:

ОКРУГЛВНИЗ аналогична предыдущей функции, но выдает ближайшее значение, меньшее по модулю. Различие в работе вышеописанных средств видно из примеров:

Если отображение ненужных разрядов вызывает появление знаков ######, или если микроскопическая точность не нужна, измените формат ячеек таким образом, чтобы отображались только необходимые десятичные разряды.

Или если вы хотите округлить число до ближайшего крупного разряда, например, тысячной, сотой, десятой или единицы, используйте функцию в формуле.

С помощью кнопки

Выделите ячейки, которые нужно отформатировать.

На вкладке Главная выберите команду Увеличить разрядность или Уменьшить разрядность, чтобы отобразить больше или меньше цифр после запятой.

С помощью встроенного числового формата

На вкладке Главная в группе Число щелкните стрелку рядом со списком числовых форматов и выберите пункт Другие числовые форматы.

В списке Категория выберите значение Денежный, Финансовый, Процентный или Экспоненциальный в зависимости от типа ваших данных.

В поле Число десятичных знаков введите число знаков после запятой, которые вы хотите отображать.

С помощью функции в формуле

Округлите число до необходимого количества цифр с помощью функции ОКРУГЛ. Эта функция имеет только два аргумента (аргументы — это части данных, необходимые для выполнения формулы).

Первый аргумент — это число, которое необходимо округлить. Он может быть ссылкой на ячейку или числом.

Второй аргумент — это количество цифр, до которого необходимо округлить число.

Предположим, что ячейка A1 содержит число 823,7825. Вот как можно округлить его.

Чтобы округлить до ближайшей тысяч и

Введите =ОКРУГЛ(A1;-3), что равно 100 0

Число 823,7825 ближе к 1000, чем к 0 (0 кратно 1000 )

В этом случае используется отрицательное число, поскольку округление должно состоятся влево от запятой. Такое же число применяется в следующих двух формулах, которые округляют до сотен и десятков.

Чтобы округлить до ближайших сотен

Введите =ОКРУГЛ(A1;-2), что равно 800

Число 800 ближе к 823,7825, чем к 900. Наверное, теперь вам все понятно.

Чтобы округлить до ближайших десятков

Введите =ОКРУГЛ(A1;-1), что равно 820

Чтобы округлить до ближайших единиц

Введите =ОКРУГЛ(A1;0), что равно 824

Используйте ноль для округления числа до ближайшей единицы.

Чтобы округлить до ближайших десятых

Введите =ОКРУГЛ(A1;1), что равно 823,8

В этом случает для округления числа до необходимого количества разрядов используйте положительное число. То же самое касается двух следующих формул, которые округляют до сотых и тысячных.

Чтобы округлить до ближайших сотых

Введите =ОКРУГЛ(A1;2), что равно 823,78

Чтобы округлить до ближайших тысячных

Введите =ОКРУГЛ(A1;3), что равно 823,783

Округлите число в большую сторону с помощью функции ОКРУГЛВВЕРХ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в большую сторону. Например, если необходимо округлить число 3,2 до ноля разрядов:

=ОКРУГЛВВЕРХ(3,2;0), что равно 4

Округлите число вниз с помощью функции ОКРУГЛВНИЗ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в меньшую сторону. Например, необходимо округлить число 3,14159 до трех разрядов:

=ОКРУГЛВНИЗ(3,14159;3), что равно 3,141

Совет: Чтобы познакомиться с другими примерами и поработать с ними в книге Excel Online, см. статьи Функция ОКРУГЛ,Функция ОКРУГЛВВЕРХ и Функция ОКРУГЛВНИЗ.

Стандартный десятичный разделитель для чисел можно настроить в параметрах Excel.

Щелкните Параметры (в Excel 2010–2016) или нажмите кнопку Microsoft Office и выберите Параметры Excel (в Excel 2007).

В категории Расширенные параметры нужно выбрать пункт Параметры правки, а затем установить флажок Автоматическая вставка десятичной запятой.

В поле Число знаков после запятой введите положительное число для количества цифр справа от запятой или отрицательное число для количества цифр слева от запятой.

Примечание: Например, если ввести 3 в поле Число знаков после запятой, а затем — 2834 в ячейке, то значение будет равно 2,834. Если ввести –3 в поле Число знаков после запятой, а затем — 283 в ячейке, то значение будет равно 283000.

Нажмите кнопку ОК.

В строке состояния будет отображаться индикатор Фиксированный десятичный формат.

Выберите ячейку на листе и введите нужное число.

Примечание: Установка флажка Фиксированный десятичный формат не влияет на уже введенные данные.

Чтобы не использовать для числа параметр "Фиксированный десятичный формат", при его вводе добавьте десятичную запятую.

Чтобы удалить десятичные запятые из чисел, введенных с использованием фиксированного десятичного формата, сделайте следующее:

Щелкните Параметры (в Excel 2010–2016) или нажмите кнопку Microsoft Office и выберите Параметры Excel (в Excel 2007).

В категории Расширенные параметры в разделе Параметры правки снимите флажок Автоматическая вставка десятичной запятой.

В пустой ячейке введите число, соответствующее числу десятичных знаков, которое вы хотите удалить, например 10, 100 или 1000.

Например, введите 100 в ячейке, если числа содержат два десятичных знака и вы хотите преобразовать их в целые числа.

На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать (или нажмите клавиши CTRL+C).

Выделите на листе ячейки, содержащие числа с десятичными разрядами, которые вы хотите изменить.

На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

В диалоговом окне Специальная вставка в разделе "Операция" выберите Умножить.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

В статье рассмотрено, как округлить число в Excel с помощью различных функций, таких как ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ и другие методы округления. Также приведены примеры формул, как округлить до целого числа, до десятых, до тысяч, до 5, 10 или 100, как округлить кратному числу, а также много других примеров.

Округлить число в путем изменения формата ячейки

Если вы хотите округлить числа в Excel исключительно для визуальной презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  1. Выберите ячейку с числами, которые вы хотите округлить.
  2. Откройте диалоговое окно « Формат ячеек », нажав Ctrl+1 или щелкните правой кнопкой мыши по ячейке и выберите « Формат ячеек » в контекстном меню.

Как округлить число в Excel – Формат ячеек
  1. Во вкладке « Число » выберите « Числовой » или « Денежный » формат и введите число десятичных знаков, которое вы хотите отобразить в поле « Число десятичных знаков ». Предварительный просмотр, как будет округлено число отобразится в разделе « Образец ».
  2. Нажмите кнопку « ОК », чтобы сохранить изменения и закрыть диалоговое окно.

Как округлить число в Excel – Округлить число, изменением формата ячейки

Обратите внимание! Этот метод изменяет формат отображения без изменения фактического значения, хранящегося в ячейке. Если вы ссылаетесь на эту ячейку в любых формулах, то во всех вычислениях будет использоваться исходное число без округления. Если вам необходимо фактически округлить число в ячейке, то используйте функции округления Excel.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис :

Число — любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов — количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как округлить число в Excel – Как округлить число до тысячных
  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как округлить число в Excel – Примеры формул, как округлить число, функцией ОКРУГЛ

Как округлить число в большую сторону функцией ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число вверх (от 0) до заданного количества цифр.

Синтаксис :

Число — число для округления.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Вы можете указать как положительные, так и отрицательные числа в этом аргументе, и он работает как число_разрядов функции ОКРУГЛ, описанной выше, за исключением того, что число всегда округляется в большую сторону.

Как округлить число в Excel – Примеры формул, как округлить число в большую сторону, функцией ОКРУГЛВВЕРХ

Как округлить число в меньшую сторону функцией ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ в Excel делает противоположное тому, что делает ОКРУГЛВВЕРХ, т. е. округляет число вниз.

Синтаксис :

Число — число, подлежащее округлению.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Работает как аргумент число_разрядов функции ОКРУГЛ, за исключением того, что число всегда округлено в меньшую сторону.

Следующее изображение демонстрирует, как округлить число в Excel в меньшую сторону функцией ОКРУГЛВНИЗ в действии.

Как округлить число в Excel – Примеры формул, как округлить число в меньшую сторону, функцией ОКРУГЛВНИЗ

Так выполняется округление чисел в Excel. Надеюсь, теперь вы знаете, как среди всех этих способов, как округлить число в Excel, выбрать наиболее подходящий для ваших нужд.