Определим день недели для заданной даты в ячейке. Существует несколько решений в зависимости от того результата, который мы хотим получить: номер дня недели (1 — Пн, 2- Вт, . ), текстовую форму (Понедельник, Вторник, . ) или просто можно изменить формат ячейки.

День недели можно быстро отобразить с помощью Пользовательского формата. Пользовательский формат можно ввести через диалоговое окно Формат ячеек, вкладка Число, (все форматы), нажав CTRL+1. Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб) или ДДДД (будет отражено Суббота).

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом (см. файл примера ):
=ТЕКСТ(01/01/10;"дддд")

Формула вернет текстовое значение "суббота".

Для определения дня недели через числовую форму (понедельник=1; вторник=2, …) существует функция ДЕНЬНЕД() , английская версия WEEKDAY().

Если дата находится в ячейке А1, то формула =ДЕНЬНЕД(A1;2) вернет день недели. Номер 1 соответствует понедельнику.

Для того, чтобы вывести день недели на английском языке используйте формулу = ТЕКСТ(A6;"[$-809]ДДД")

Другие статьи на эту тему можно найти в разделе Неделя, День недели.

Часто в работе нам требуется определить день недели в Excel по заданной дате.
Давайте разберем несколько простых способов как это можно сделать.

День недели можно отобразить двумя способами: с помощью использования формата ячейки и посредством формул.

Использование формата ячейки

Зададим ячейке с датой определенный формат. В Excel есть два типа формата ячеек, отображающих день недели:

  • ДДД — краткий формат дня (Пн, Вт, Ср, Чт, Пт, Сб, Вс);
  • ДДДД — полный формат дня (Понедельник, Вторник, Среда, Четверг, Пятница, Суббота, Воскресенье).

Нажимаем правой кнопкой мыши на ячейку, выбираем Формат ячеек -> Число -> Все форматы и вводим новый формат "ДДД" или "ДДДД" в строчку Тип:

Изменение формата ячейки

Использование формул

Определить день недели также можно с помощью функции ТЕКСТ:

ТЕКСТ(значение; формат)
Форматирует число и преобразует его в текст.

  • Значение(обязательный аргумент) — числовое значение;
  • Формат(обязательный аргумент) — численный формат в виде текста в кавычках (например, "ДДД" или "ДДДД").

В данном случае выбираем в качестве значения ячейку с датой A2 и задаем формат как "ДДД" или "ДДДД", в результате получаем день недели как вторник:

Определение дня недели с помощью функции ТЕКСТ

ДЕНЬНЕД(дата_в_числовом_формате; [тип])
Возвращает число от 1 до 7, соответствующее номеру дня недели для заданной даты.

  • Дата в числовом формате(обязательный аргумент) — числовое значение;
  • Тип(необязательный аргумент) — тип возвращаемого значения.
  • 1 — неделя от воскресенья (число 1) до субботу (число 7);
  • 2 — неделя от понедельника (число 1) до воскресенья (число 7);
  • 3 — неделя от понедельника (число 0) до воскресенья (число 6).

В нашем случае в качестве даты в числовом формате вводим ячейку с датой A2 и задаем тип как 2, в результате получаем значение 2 (т.е. вторник):

Определение дня недели с помощью функции ДЕНЬНЕД

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Предположим, что вы хотите вывести в ячейке день недели, например "Понедельник", а не саму дату, такую как "3 октября 2005 г.". Это можно сделать несколькими способами.

Примечание: Снимок экрана в этой статье был взят в Excel 2016. Если вы используете другую версию, то в ней может быть немного другой интерфейс, но если не указано иное, функции будут такими же.

Форматирование ячеек для отображения дня недели

Выделите ячейки, содержащие даты, которые вы хотите вывести в виде дней недели.

На вкладке Главная в списке числовой формат выберите пункт другие числовые форматы, а затем откройте вкладку число .

В поле Числовые форматы выберите пункт (все форматы) и в поле Тип введите значение дддд, чтобы отображались полные названия дней недели ("понедельник", "вторник" и т. д.), либо ддд, чтобы отображались сокращенные названия ("Пн", "Вт", "Ср" и т. д.).

Преобразование дат в дни недели в текстовом формате

Для выполнения этой задачи используйте функцию ТЕКСТ.

Пример

Скопируйте указанные ниже данные на пустой лист.